Email notifications

  • The WAM 22 TICKETS and details can be found HERE
2022 The WAM show

therealolis

Just Oli
Wammer Plus
Nov 1, 2021
78
13
58
Dumfries&Galloway
AKA
Oli
HiFi Trade?
  1. No
I can't see that this has been asked before, and I suspect it's related to the new forum: I have not received a notification email of any description since January 31st.

I have checked my settings, there are numerous checkboxes and they are all ticked:

1647523325555.png

The "Watched Threads" overview has a long list of threads I watch. I just noticed that there may be something wrong here - there's a little checkbox on the right edge of each entry, where it says "Email", and this is not checked in most cases:

1647523465913.png

Granted, I had not noticed this before. However, after it first occurred to me that I wasn't getting email notifications, I made a point of watching out for the "email" setting whenever I clicked the "Watch" button for a thread. So it seems to me that my choice has not been retained correctly by the system - and of course there must be a completely different reason why the general message types mentioned in the preferences (news, updates, activity summary) don't arrive either.

I have now checked a few of the boxes in the "Watched Threads" overview - will see if this changes anything.
 

therealolis

Just Oli
Wammer Plus
Nov 1, 2021
78
13
58
Dumfries&Galloway
AKA
Oli
HiFi Trade?
  1. No
Quick follow-up. Just after posting this new thread, I had another look at the "Watched Threads" overview. The new thread is there, as it should be, but it's not marked for email notifications.

1647523729843.png

I'm wondering if there's some other place where I may have configured things to "never send me email" or similar? I'm sure I wouldn't have done this consciously - back with the old forum, I received loads of emails all the time, and I don't mind.
 

StingRay

Legend Wammer
Wammer
Apr 27, 2016
9,103
4,549
148
Suffolk, UK
AKA
Ray
HiFi Trade?
  1. No
All my emails from the WAM are going into my spam folder.

I do get notifications if someone sends me a message (conversation).
 

therealolis

Just Oli
Wammer Plus
Nov 1, 2021
78
13
58
Dumfries&Galloway
AKA
Oli
HiFi Trade?
  1. No
All my emails from the WAM are going into my spam folder.

That's unfortunately not what's happening here.

I just noticed one more thing: when I checked some of the "Email" checkboxes on the "Watched Threads" page earlier, these settings didn't stick. I went back just now to make sure I had the checkbox checked for this thread - and now none of them are checked anymore. I guess that's clearly the problem for some reason - these "notify by email" settings are simply not persisted for my account, whether I set them manually or whether they are configured automatically (if that ever happens).
 

Roo

👻
Staff member
Mar 19, 2020
2,695
13
955
183
North Yorks
AKA
Ruairidh
HiFi Trade?
  1. No
Hi this issue has been fixed today.

let us know if it persists.

p.s. may not take effect instantly so give it a few hours.
 

therealolis

Just Oli
Wammer Plus
Nov 1, 2021
78
13
58
Dumfries&Galloway
AKA
Oli
HiFi Trade?
  1. No
Okay, one more strange thing: I now found three notification emails in the Spam folder. So apparently the notifications work now, since half five or so. However, when I replied previously at half six, I had just made a test by checking the box for "Email" in several entries on the "Watched Threads" page, and the setting was still not retained. I tried it again just now, but that still doesn't work. I wouldn't mind of course - as long as the emails arrive. Perhaps that's one detail that will resolve itself later?

Meanwhile, the reason why the emails go to Spam is that there are issues with the email setup of your domain. I suspect this has something to do with SPF/DMARC. If you'd like, I can help somebody look into this - it would mean that emails are more reliably delivered for forum members, less likely to vanish in Spam folders. Let me know if I can help.
 
  • Upvote
Reactions: StingRay

therealolis

Just Oli
Wammer Plus
Nov 1, 2021
78
13
58
Dumfries&Galloway
AKA
Oli
HiFi Trade?
  1. No
As far as I can see, nothing has changed - in fact here’s the incoming notification of your message:

1648068838866.jpeg

At the top, you can see the notification by my email client which indicates the same DMARC failure I saw earlier. I have also received at least one other notification a bit later, with the same warning.

I have configured my email system to accept incoming emails from your sender address and /not/ drop them in spam, so I don’t have that problem anymore - but I believe others would still see the same result. Many email systems handle DMARC failure as a strong indicator that an email should be classed as spam - and many won’t even display the sort of message you see in my screenshot.

My email provider documents the message and its meaning at this URL.
 

therealolis

Just Oli
Wammer Plus
Nov 1, 2021
78
13
58
Dumfries&Galloway
AKA
Oli
HiFi Trade?
  1. No
I had a quick check at https://dmarcian.com/domain-checker/ - it says that the DMARC record for hifiwigwam.com is valid but useless, but it flags the SPF as invalid. At a closer glance at https://dmarcian.com/spf-survey/?domain=hifiwigwam.com , I notice what a simple “dig hifiwigwam.com TXT” also told me but I wasn’t paying attention - there are actually two SPF entries, only one of which includes the server IP 93.114.184.40, which is used to send your notification emails. I suspect that SPF fails simply - and perhaps randomly - because the wrong SPF entry is picked depending on mail server implementation.

Looking at the details of the DMARC warning issued by the service, I believe the “p=none” flag is judged to be peculiar since DMARC is basically configured (”dig _dmarc.hifiwigwam.com TXT” shows me the entry). I’m not entirely clear why this problem results in a DMARC fail, but I guess it’s possible that this happens in conjunction with the SPF issue. I stopped investigating at this point - I offered before but I don’t want to impose.
 

Roo

👻
Staff member
Mar 19, 2020
2,695
13
955
183
North Yorks
AKA
Ruairidh
HiFi Trade?
  1. No
I had a quick check at https://dmarcian.com/domain-checker/ - it says that the DMARC record for hifiwigwam.com is valid but useless, but it flags the SPF as invalid. At a closer glance at https://dmarcian.com/spf-survey/?domain=hifiwigwam.com , I notice what a simple “dig hifiwigwam.com TXT” also told me but I wasn’t paying attention - there are actually two SPF entries, only one of which includes the server IP 93.114.184.40, which is used to send your notification emails. I suspect that SPF fails simply - and perhaps randomly - because the wrong SPF entry is picked depending on mail server implementation.

Looking at the details of the DMARC warning issued by the service, I believe the “p=none” flag is judged to be peculiar since DMARC is basically configured (”dig _dmarc.hifiwigwam.com TXT” shows me the entry). I’m not entirely clear why this problem results in a DMARC fail, but I guess it’s possible that this happens in conjunction with the SPF issue. I stopped investigating at this point - I offered before but I don’t want to impose.
Hi, yes this was the issue it got fixed early last week but it wasn't live instantly, all emails should be going into your inbox now.
 

therealolis

Just Oli
Wammer Plus
Nov 1, 2021
78
13
58
Dumfries&Galloway
AKA
Oli
HiFi Trade?
  1. No
Hi, yes this was the issue it got fixed early last week but it wasn't live instantly, all emails should be going into your inbox now.

At this time I’m still seeing the same annotations by my email system, the last email came through at 8:05, 33 minutes ago. The DMARC and SPF checkers also still show issues. Depending when you made the changes, it’s possible that DNS propagation is taking its time - it can take surprisingly long for systems around the world to update their caches. Hopefully the issues will be gone once that happens.

Thanks for the update 👍