JohnnyBuchan

My new LP12... this can't be right???

Recommended Posts

After weeks of redecorating I finally managed to unbox my new LP12 and after a couple of days of playing I'm sure something can't be right... I thought it sounded a bit lifeless until I compared the same piece of music streamed at CD quality and found that the streamed version simply blows it away making the LP12 sound dull and 2 dimensional by comparison even when playing decent heavyweight vinyl.

So all this makes me think something must be wrong, I've checked and double checked that the deck is sitting level on the rack.

Spec is New Chassis, Trampolin 2, Kore, Lingo 1, new Majik Arm, AT-OC9XEN MC Cartridge, ADSM on-board Phono stage.

Built by Peter at Cymbiosis so doubt very much it has anything to do with the way it's been put together!

Your thoughts/advice would be much appreciated.

Hope everyone is staying safe and well.

Rgds JB

Share this post


Link to post
Share on other sites

Did you hear it at Cymbiosis??

Share this post


Link to post
Share on other sites

Just a though but is your phono stage set for MC and not MM.?

Peter tests all his builds in the shop and plays to demonstrate.B|

Share this post


Link to post
Share on other sites

Johnny, all sounded well in the shop here.

In the first instance I'd suggest giving me a ring when convenient as I am contactable.

The Cymbiosis phone will divert to my mobile during works hours, otherwise please email me and I can call you if you prefer to discuss.

KR

Peter

Share this post


Link to post
Share on other sites
8 minutes ago, Mr Kandid said:

Just a though but is your phono stage set for MC and not MM.?

Peter tests all his builds in the shop and plays to demonstrate.B|

On the basis of the below... I'd say it is MC although I think it is a physical configuration selection rather software configurable (as far as I can see anyway). I haven't actually looked at the board.

Peter had been testing it and I heard it when I picked it up, that was a few weeks ago but it sounded fine to me there.

864785544_Screenshot2020-03-27at12_43_18.png.0f09c7cb55906ea96b48a66844592115.png

Share this post


Link to post
Share on other sites
1 minute ago, Cymbiosis said:

Johnny, all sounded well in the shop here.

In the first instance I'd suggest giving me a ring when convenient as I am contactable.

The Cymbiosis phone will divert to my mobile during works hours, otherwise please email me and I can call you if you prefer to discuss.

KR

Peter

Thank you Peter, I'll give you a buzz shortly.

Share this post


Link to post
Share on other sites
20 minutes ago, JohnnyBuchan said:

I'd say it is MC although I think it is a physical configuration selection rather software configurable (as far as I can see anyway). I haven't actually looked at the board.

You can see how the board is set in Konfig; I forget on precisely which configuration page, as my KEDSM does not have an inbuilt phono stage. Changing the input does indeed require the physical reorientation of the input stage daughter board. IIRC, the analogue input boards are set to MC by default on the ADSM. Unless upgraded, the MDSM is MM only.

David

Share this post


Link to post
Share on other sites

Not sure if this helps but I have a Majik LP12 using an Akurate System Hub which ships with MC by default, after having it reconfigured for MM my board does show MM in Konfig.

image.png.ebe08a2c04a5672ec670f23265e6cc78.png

Share this post


Link to post
Share on other sites

Thanks Chaps, and thanks to Peter for getting in touch so rapidly!

Have physically checked the phono board and it is definitely configured for MC.

General consensus does point to the phono stage, to quote Peter it was indeed "singing its little heart out" in the shop.

Next step is to try a different phono stage... wonder if anyone else is using the phono stage in their ADSM, how does it compare to streamed music?

JB

  • Like 1

Share this post


Link to post
Share on other sites

Using mine in MM mode at present, no issues. 

On leaving the shop I guess it was partly dissembled and packed, so you need to logically walk thorough all the steps you went through once unpacking to ensure you set it back up again okay.   Ie  adding the counter, weight, balancing,  adding playing weight.....  Actually plugged into the Ph socket not the adjacent line in?  

Share this post


Link to post
Share on other sites
27 minutes ago, 9designs said:

Using mine in MM mode at present, no issues. 

On leaving the shop I guess it was partly dissembled and packed, so you need to logically walk thorough all the steps you went through once unpacking to ensure you set it back up again okay.   Ie  adding the counter, weight, balancing,  adding playing weight.....  Actually plugged into the Ph socket not the adjacent line in?  

yep done all that too :^

Share this post


Link to post
Share on other sites

I use the MC board in my System Hub and it is exceedingly good so that is not your issue (and we get to try loads of different ones).

Strongly suspect something is wrong with the deck setup.

CJ

Share this post


Link to post
Share on other sites

Thanks Johnny, I try my level best as always and it is a strange one and something that isn't helped by the COVID19 situation but we will find a way to resolve whatever the issue is.

CJ read above. The LP12 was tested and was absolutely fine and sounding fab. - Only stick the knife in if there is proper justification please!

KR

Peter

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.