New Asus/ Ryzen build hates USB sound interfaces

Recommended Posts

(Long, TL/DR post - Sorry!!)

Hello all, I've built about twenty new builds for friends and family and repaired so many PC's and laptops over the years I've lost count. I decided it was time I treated myself to a new build after ten years, What I've put together, Mobo, processor, RAM. Processor and RAM are on the ASUS QVL:

Asus Tuf B450 Gaming plus motherboard (latest BIOS 2022)

AMD Ryzen 5 3600

32Gb Corsair DDR4 3600 RGB Pro

Same graphics card (have to wait for an upgrade) MSI Radeon R9 290

SSD's/HDD's... Windows 10 64 Pro.

(Old build was Gigabyte 890.... AMD Phenom ii X4 965 BE, 16 Gb DDR3 1666 and never an issue with USB sound cards)

I do some down mixing and tracking from the studio at home, I've got both  Focusrite Scarlett 8i6 vers.1 and vers.3 USB interfaces, the new build hates both of the cards and will not correctly recognise either despite latest drivers from Focusrite, Scarlett software or Pro-tools or other DAW's, even using compatible Focusrite or Windows drivers. They will partially work but I cannot physically control the monitor/mains output and have to rely on Windows volume control (ugh!) for output to mains out (active monitors). This is a motherboard/USB/Windows issue but all chipset drivers are up to date, I've also tried an Alesis i/o2 with a little more success as I can control main out this just a glorified USB card and isn't reliable for pro audio.

The overriding problem is when shutting down/booting/entering sleep/waking from sleep there is a loud thump from the monitors indicating that the USB is turned off when in sleep/shutdown/boot/wake mode. In the UFEI I've disabled Erp (power saving), Disabled any power saving  state modes (S3/S5 etc), Enabled both USB power state ON (bloody confusing Enable/Disable modes) and according to Asus (kind of/useless) that this 'might' keep USB powered in sleep/off/on etc. Nope! In Windows the Power plan is Ryzen Balanced but I've disabled USB selective suspend, and even plugging all of the interfaces using a powered USB hub - nope.

I've scoured the internet and just about every bleedin' article is how to disable USB power whilst in standby/off! GRRRR! This seems to affect a few other MB's so isn't just an Asus thing, All I want is not to have the thump when the PC wakes without resorting to turn off the Sub and main monitors before entering sleep/off/waking/boot etc. 

Any ideas?

Muchas gracias

Share this post

Link to post
Share on other sites

Interesting problem!

First I agree you should rule out all issue related to power saving.

Then try the troubleshooting steps here:

If you can get hold of a cheap powered (own power supply) USB hub, try putting that in chain between the pc and the audio interface. It may be enough to keep the power on to the interface despite what Windows is playing at.

You could try a cheap internal pcie USB card too, in case it is buggy USB controller on the mobo.

If all of that doesn't fix it then, given that you are not getting full functionality on the interface, I wonder if it is more a driver issue than a power management issue?

I would suggest to do a completely fresh install of windows using the latest iso, and don't load on your motherboard's own drivers. Instead use Windows update. At least until you have got the sound cards working.


Sent from my SM-N960F using Tapatalk

Share this post

Link to post
Share on other sites
Posted (edited)

Hey Chis, massive thanks for the comprehensive reply!

The Focusrite site has been useful but its it doesn't really cover the issue I'm having, I've had the Focusrite Scarlett 8i6 vers.1 from the year dot, the vers.3 was purchased a couple of years ago and is used one of the practice rooms in the studio, I've tested both on both my laptops and the laptop in the studio without any issues at all - no thump...

The build was done from scratch, new SSD's, HDD and the latest fresh Windows 10 x64, originally I didn't install the mobo chipset drivers as Windows versions are usually spot on, however, after the on-going issues I decided to install the latest drivers from Asus but nothing has changed.

I've tried a cute little Alesis io/2 but as that's USB powered the problem still remains with on/off/sleep/wake thump. I've tried every setup with the power settings in the UEFI but still no success and all the USB ports just to see if this helps. The mobo simply will not supply power to the USB's if the PC is anything other than on - I'm getting to the point of asking for an RMA.Just a side not - I have tried all three interfaces plugged into an active USB so that they are 'always on' but as soon as the pc enters on/off/sleep/wake still getting thump...

Before I loose the plot I'll get hold of another mixer that supports input switching from USB/line in etc so before on/off/sleep/wake is in action I can switch the input other than USB. The PCIE card is also on my list (great minds and all that:geek:! ) as there is power to the mobo during either sleep or shutdown/boot as the Corsair RGB will stay on unless I switch it off before sleep/shutdown etc. Finding a PCIE card with balanced out is proving to be a hassle as most are only line out - however ouputting intto the mixer mains out to monitors will should be a solution.... After we open fully I'll start making some money again, COVID has nearly ruined the business entirely but there is light at the end of the tunnel.

Again, a massive thank you for your impressive input :flowers:


Edited by Strider

Share this post

Link to post
Share on other sites

Hi Mark

My pleasure.

It seems that the focusrite products don't have anti thump protection until you move up the range:

Have you tried plugging a mobile phone into the same port to see whether it continues to charge when the pc is sleeping or switched off? (or even better, a more basic USB device that is unlikely to have any active power management circuitry in it; I don't know if phones can take a port out of sleep mode these days).

I e. Is it possible that the pop isn't caused by loss of power to the device but loss of signal from the drivers?

Then there is the wider issue that your drivers aren't working properly anyway as you can't set the hardware volume.

I'm clutching at straws a bit but have you tried disabling / enabling (opposite of however you have it currently set) exclusive mode?

Have you been onto Focusrite support?

Fwiw the pcie card I am suggesting is a USB card (you could even try a cheap USB 2.0 p
card on basis the drivers are less complex) not a whole new sound card although the latter could work to bypass USB entirely!

Sent from my SM-N960F using Tapatalk

  • Upvote 1

Share this post

Link to post
Share on other sites

Hi Jamster, again a huge thanks for you input here.

It turned out the motherboard was dicky and Asus swapped it out but the issue still wasnt fully resolved! It turns out the UFEI is actually incorrect when it complex to USB3 and USB2 always on and the power delivery was to megre when the system isn't running windows, there were multiple settings I had to try in the lower setup that even Asus said they've never needed to adjust or tinker with.

They then asked me to email a copy of my UFEI profile and sure enough they will implement the settings in this next update release. Even better was they fully reimbursed the full cost of the motherboard as a good will gesture!

Edited by Strider
  • Like 2
  • Upvote 1

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.