Jump to content

Konfig/network problems


brenng44
 Share

Recommended Posts

Konfig/cannot load Majik DSM in "Main Room" ... I can see the DSM directly via network address, but KOmfig csnnot 'see it...  kazoo will not connect,=> "Waiting for rooms"

I submitted the problem to Linn suport over a week ago... they suggested it might be the firewalls on my mac.... tries turning them off temporarily, which worked for an hour.. thn disappeared again- also sdont want to make ny hoeme netorkisecuree... so whatcan I do with settngs on macOS secuirty/privacy... and or with Linn settings?

Appreciate any ideas to help me out of this mess.

Link to comment
Share on other sites

The problem with Konfig, and Kazoo is very common, I have come across it at least a few million times, and it is nothing with firewall (contrary to what Linn Support has been saying).

1) I think you can fix the problem with Kazoo by selecting and rescanning a correct subnet for your home network as follows

image.thumb.png.5e17b49ddcc764bb1450cfa168dc7d54.png

2) As with Konfig, there is a big chance that Konfig will not find your streamer if you are using a Windows 10  PC/latop, MacOS has no problem. But if you are using a Windows 10 machine, there are 2 options that you can manage your streamer without Konfig.

Either

  a) Accessing it directly by entering its IP to a browser address bar

Or

  b) Just go to https://www.linn.co.uk/account/music-systems. I think you need to register streamer to Linn if you want to do it this way.

Btw, there is no security setting on MacOS, it just works, unless in an extremely rare situation you need to deal with firewall.

Edited by cspgqqt
Link to comment
Share on other sites

34 minutes ago, cspgqqt said:

2) As with Konfig, there is a big chance that Konfig will not find your streamer if you are using a Windows 10  PC/latop, MacOS has no problem. 

That’s interesting. I have no experience of Macs but have never had an issue with Konfig on Windows 10 machines. It’s always found whichever DS I had at any time, despite Kazoo and later the new app giving me that dreaded “waiting for room” from time to time.

Mick

Link to comment
Share on other sites

Yes, I know. I had never had the problem of Konfig unable to find my Linn Klimax on any Windows 10 machine that I have until I bought a top-of-the Dell XPS 17 laptop a few weeks ago. I could not use Konfig on this Dell laptop to find my Linn Klimax for whatever reason, same network, latest Windows 10, no firewall issue, no root cause that I can figure out as to why Konfig does not work on this $4,500 laptop.

Personally, I think software is a Linn weak point. They should have hired better software engineers.

Edited by cspgqqt
Link to comment
Share on other sites

1 hour ago, cspgqqt said:

Yes, I know. I had never had the problem of Konfig unable to find my Linn Klimax on any Windows 10 machine that I have until I bought a top-of-the Dell XPS 17 laptop a few weeks ago. I could not use Konfig on this Dell laptop to find my Linn Klimax for whatever reason, same network, latest Windows 10, no firewall issue, no root cause that I can figure out as to why Konfig does not work on this $4,500 laptop.

Personally, I think software is a Linn weak point. They should have hired better software engineers.

Did your Dell laptop come with McAfee?  If so, try uninstalling it and then see if the laptop can find your Linn Klimax OK.

Link to comment
Share on other sites

  • 3 months later...
On 05/09/2020 at 03:50, cspgqqt said:

Yes, I know. I had never had the problem of Konfig unable to find my Linn Klimax on any Windows 10 machine that I have until I bought a top-of-the Dell XPS 17 laptop a few weeks ago. I could not use Konfig on this Dell laptop to find my Linn Klimax for whatever reason, same network, latest Windows 10, no firewall issue, no root cause that I can figure out as to why Konfig does not work on this $4,500 laptop.

Personally, I think software is a Linn weak point. They should have hired better software engineers.

And if only linn can admit to this problem.  They are in denial.  I have same problem, not only kazoo but linn app on iOS is on a endless search for my linn dsm. 

Link to comment
Share on other sites

Super Wammer

@brenng44 it's more likely an issue with your home setup imho. if turning the firewall fixed it then most likely its a problem with your firewall. check if you have upnp enabled, alternatively you might need to open up the DLna port (26125 by default I think).

Generally worth pointing out that these issues can be very complex, it depends on how you have each of the devices connected, are they all wired into the same switch? are you using wifi? what firewalls do you have? are you using an ISP hub?

are your software versions all up to date?

are you cables all up to spec? no kinks or sharp bends?

these issues are pretty hard to debug, and shouldn't be something that Linn get the blame for, the number of possible combinations is mind boggling.

I would start by stripping everything back to basics if you're having problems

  • disconnect all the part of the system which you need for music
  • connect them all via cables to the same switch - check you have link lights 
  • make sure they all have IP addresses (usually they get this from your ISP router so make sure that's connected)
  • turn off firewalls and anti virus on the computer with Konfig and Kazoo
  • restart everything, including your computer & UPNP server
  • When everything is back up make sure your UPNP server has started
  • make sure the computer can ping the IP address of the DSM
  • make sure the computer can ping the UPNP server
  • open up the DSM webpage as per the advice above, if it's ok
  • open up Konfig 
  • open up kazoo
  • if everything is working then you can start putting things back to how they were, do it 1 step at a time while making sure nothing breaks
  • if anything you add back in breaks things, that might suggest what e.g. if you turn on your firewall it suggests that's the issue

if you find an issue at any step then it suggests it's that component which is the problem, try and swap it out if you can, or try to do things in a different way to remove it from the chain.

happy to help more but each of you with issues will have to give specifics, general "this software is crap" doesn't really help pinpoint why you are having problems :)

I can't actually think of any cases where issues like this turned out to be due to the Linn software, it's almost always due to individuals personal setup/systems/network/computers....

  • Like 1
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...