Jump to content

How to “clean” USB port on Win10 PC for audio use


Recommended Posts

Hi everyone.

For me the (second) most convenient way of home music reproduction is simply to use laptop as transport. 

First source is CD transport. (Streamer won’t be required.)

For now, I am using standard Asus laptop, USB output to Mutec MC3+USB, spdif output to Sabaj D5 DAC. I am happy with the sound as the Mutec takes care after signal and reclocking very well.

It is just £1k device in the chain I have to use even though Sabaj DAC has direct USB input.

When I use laptop USB output directly to Sabaj, I experience occasional pops/clicks, those are disturbing. Even one pop per 5 minutes is. It can also happen when moving cursor using pad (not mouse).  Mutec handles “dirty” signal from USB port nicely.

Sabaj has also I2S input through HDMI kind of port, just for information. Laptop has also HDMI output, unfortunately that is not how it could work as far as I know.

So the simplest way to play music from laptop would be directly to DAC. Is it possible to get rid of the USB port data signal dirtiness (causing the pops and clicks) within OS settings or maybe connect the DAC differently?

Link to post
Share on other sites

Hi Ras

It might help if you say which Windows OS you are running and which Media Player you use for output.

Did you look here ?

http://www.sabaj.com.cn/en/services.asp?id=79

Windows will generally need a driver or Asio for playback.

Don't use the generic driver proved by Windows but install the one from Sabaj

ronnie

Link to post
Share on other sites

Hi Ronnie,

thank you very much for the advice and link.

I have downloaded the driver and update, both of them are installed, at the end, it seems the pops calmed down a bit, not sure it is definite solution though.

The OS is Windows 10, the player Groove.

It might be some other players can treat purity of sound differently.

As there are plenty of them, which one is the best in that respect?

I also suspect two other things can play role. The design of PCB, then influence of other signal paths within PC and tasks running in background of PC, not necessary to be ON.

Link to post
Share on other sites

hey Ras

I don't use Windows much for music playback.

There are a lot of players if you google.

I like foobar

https://www.foobar2000.org/

It does seem a bit complicated but practice makes perfect

https://diyaudioheaven.wordpress.com/digital/pc-software/foobar-2000-for-dummies/

and there are a lot of skins, just search

https://www.hifiwigwam.com/forum/topic/55159-the-best-looking-foobar-skinfclcfg-i-found-it/

https://www.deviantart.com/search?q=foobar skins

ronnie

  • Upvote 1
Link to post
Share on other sites

Hi Ras,

Have you checked your audio buffer size and latency?  Win10 updates reduced audio latency  from previous larger buffer and latency.  That is enough to invoke clicks pops.  Groove is not optimised for hi res files - think kids and 128mps MP3s.  I have unistalled it.

Win10 prioritises so many other functions in OS and audio output is probbaly low in cpu priorities compared to say video.

You can tweak setting yourself 

https://support.focusrite.com/hc/en-gb/articles/207355205-Optimising-your-PC-for-Audio-on-Windows-10

Or you can go into waspi type setting using developer tools (API)  Not as daunting as it sounds.

https://docs.microsoft.com/en-us/windows-hardware/drivers/audio/low-latency-audio

Before you do anything, tray another USB port for output and also update usb drivers. 

If you are using a Foobar Type program - there may be output buffer isze and latency settings in SW settings.  Increase both,

Cheers

  • Like 1
Link to post
Share on other sites

 Thanks very much Garry and Ronnie for all the links. Didn’t explore everything yet, but Foobar installed, where I maxed the buffer size, although didn’t find any latency settings yet.

The result is positive, when no other programs involved, the playback is without pops and clicks, when multiple programs open, there is still seldom occurrence of them, especially when moving cursor along bottom bar with docked icons, but not always, so I am almost there, that’s great!

  • Like 1
Link to post
Share on other sites

Why the reluctance on a "streamer"? It is by far the best option and doesn't need to be complicated. Audirvana on your laptop (which can stay on your lap) will stream to a Rasberry pi running minimal OS to make it act as upnp/DLNA bridge. I guarantee it will sound a good bit better than just plugging your laptop into the DAC and can be done for a damn sight less than the grand the Mutec costs. 

Link to post
Share on other sites

First clean the connections with a contact cleaner such as deoxit and check the cable for defects.

The laptop will have several USB ports and windows will have several USB busses.  Try to put the audio output on a bus that does not share USB with any of the other peripherals.  Consider connecting via spdif coaxial.  I²S would be great if your laptop supported that. 

Make sure you use WASAPI.  I don't know about Groove but in Foobar2000 (smallish footprint by the way) it is an easy download.  You use that in combination with a Windows Sounds setting to ensure your output device has exclusive control.  Also while you are in Window's sound settings be sure to turn off all notification sounds, eg sound alerts that mail has arrived.

Consider playing from RAM.  This should not make a difference as the data files are loaded into RAM prior to being played - but hey, who knows - maybe it is using Virtual RAM (ie your hard-drive as RAM).  In any event play with some buffer options in your players settings.

Consider using a windows optimiser like Fidelizer.  There are others but that is the one I use.  What these things do is to make some harmless alterations to Windows settings that give priority to your players requests.

If you are playing CDs then (1) consider converting some to the FLAC format or (2) putting the laptop on a non-vibrating surface.

Check out your DACs settings.  Be sure to be using Asynchronous mode.  Also some chips (eg the Sabre 3018) have a re-clocking feature.  There are some aftermarket re-clockers such as from Wyred4Sound that sit between your USB output and the DAC.

  • Like 1
Link to post
Share on other sites

Simply change your buffer size for the Mutec MC3+USB.
Keep increasing it until the pops/clicks are gone.

Link to post
Share on other sites
On 20/02/2021 at 13:07, PaulH said:

Simply change your buffer size for the Mutec MC3+USB.
Keep increasing it until the pops/clicks are gone.

Thank you. Forgot to tell maybe, when Mutec in chain, no problem with pops/clicks, the playback is snooth. However in that case usb/spdif conversion employed. I am looking for direct PC USB output to USB DAC input solution.

Link to post
Share on other sites
On 18/02/2021 at 19:25, Tristan said:

Why the reluctance on a "streamer"? It is by far the best option and doesn't need to be complicated. Audirvana on your laptop (which can stay on your lap) will stream to a Rasberry pi running minimal OS to make it act as upnp/DLNA bridge. I guarantee it will sound a good bit better than just plugging your laptop into the DAC and can be done for a damn sight less than the grand the Mutec costs. 

I am using the laptop’s physical cable connection to DAC, not wifi. I am on shared wifi network (a few other then mine devices connected to the same rooter). Thus I am just using the wifi for internet connection and printer. Raspberry would have to be connected to laptop through wifi (as I don’t have ethernet socket on laptop). But maybe I am missing something. Available connections are - 3xUSB A, 1xUSB C(I think), 1xHDMI, audio direct ~3mm jack for headphones.

Link to post
Share on other sites

Hi @Andrei thank you for the suggestions.

-The cables are new and all components less then 2years old, would deoxit treatment help?

-Don’t know how to identify isolated USB bus.. there is no spdif output on laptop, I think I2S is not there too.. 

-wasapi driver for Foobar installed, thank you for that suggestion, all Windows notifications sounds are off

-don’t know how to play from RAM, the laptop drive is 240GB SSD and 8GB RAM

-the Fidelizer installed, thank you for the suggestion, only free version for now, still, the laptop has to be in “calmer” state, means not multiple tabs in browser open and multiple apps open, no rush movements with mouse icon over bottom panel icons, otherwise the pops and clicks will appear despite of Fidelizer running on bacground, probably paid version is more effective, but without trying it first I won’t pay for it as it may not work..

-the laptop has no ROM drive

-the DAC USB input works in asynchrounous mode, it is Sabre ES9038PRO

For complete pops and clicks removal I have to use Mutec reclocker, it acts as USB to spdif converter too, then Mutec output is into spdif input of the DAC, the sound is probably the best with wasapi driver pull mode. However the DAC itself sounds pretty good using just its USB input. Pops and clicks are still present when “heavier” work on computer (and without Mutec employed). As for late night or relaxing listening without using the laptop for anything else, the playback is fine, the problems with pops and clicks start when laptop is used for general tasks/ internet browsing. 

Link to post
Share on other sites

@ramsden

hey Ras, here is a link which may help

https://www.soundonsound.com/techniques/eradicating-pc-audio-clicks-pops

sadly some noise can be from the dac itself; when switching between tracks of a different bit rate or even because os some grounding (lack of) issues within the dac.

There are usb connection cable which have a spilt connection at one end. One is for the data from the computer and the other can take usb power from a seperate supply.

ronnie

Link to post
Share on other sites
16 hours ago, ramsden said:

Hi @Andrei thank you for the suggestions.

-The cables are new and all components less then 2years old, would deoxit treatment help?

-Don’t know how to identify isolated USB bus.. there is no spdif output on laptop, I think I2S is not there too.. 

-wasapi driver for Foobar installed, thank you for that suggestion, all Windows notifications sounds are off

-don’t know how to play from RAM, the laptop drive is 240GB SSD and 8GB RAM

-the Fidelizer installed, thank you for the suggestion, only free version for now, still, the laptop has to be in “calmer” state, means not multiple tabs in browser open and multiple apps open, no rush movements with mouse icon over bottom panel icons, otherwise the pops and clicks will appear despite of Fidelizer running on bacground, probably paid version is more effective, but without trying it first I won’t pay for it as it may not work..

-the laptop has no ROM drive

-the DAC USB input works in asynchrounous mode, it is Sabre ES9038PRO

For complete pops and clicks removal I have to use Mutec reclocker, it acts as USB to spdif converter too, then Mutec output is into spdif input of the DAC, the sound is probably the best with wasapi driver pull mode. However the DAC itself sounds pretty good using just its USB input. Pops and clicks are still present when “heavier” work on computer (and without Mutec employed). As for late night or relaxing listening without using the laptop for anything else, the playback is fine, the problems with pops and clicks start when laptop is used for general tasks/ internet browsing. 

Connectors really only need to be cleaned once every five years or so.

The USB Bus:  you will need to go to a Windows forum.  I did check it out once.  The theory is that there are a few USB busses and if your audio connection was on the same bus as  other components (cam, mouse, keyboard, external drive etc) then windows allocates the time between those components.  (My workaround is that I avoid the normal USB2 - I use either a USB3 port for audio at the back of my PC or I2S - [I squared S]) and everything else is on USB2.  So I think your audio is optimised by being on its own USB bus.

The 9038Pro is a top of the line chip.  I do not think the reclocker I mentioned (W4S) would assist you.  I googled the Mutec but that is beyond what I know.

The Ram player is a download from https://www.foobar2000.org/components  You should check this out given your end comments.  I suspect you may be onto something with this.  It is a free shot and can be uninstalled without tears.  If computer overload is the problem given the modest HD and RAM  (my first build had 8 Mb of RAM!) then the combination of Fidelizer and RAM-Disk should get your priorities in place.  After all, who cares if an Excel window opens in one second or one millisecond?

Link to post
Share on other sites
3 hours ago, Andrei said:

The theory is that there are a few USB busses

This piece measures different noise levels in different USB ports of the same laptop:

https://archimago.blogspot.com/2018/05/measurements-computer-usb-5v-power.html

.

There are a few industrial-grade USB isolators, and maybe a USB could help too:

https://archimago.blogspot.com/2015/05/measurements-usb-hubs-and-8khz-phy.html

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...