Jump to content

Recommended Posts

Hi guys 

Just got these and added activ cards to run Ninka's active, all works great and I'm happy with the upgrade from LK85's.

Can I use channel 1 to run a centre speaker passively and how would I wire this in from the Exotic to the AV5125, I am getting confused on inputs and outputs on both pre and power amps.Any help gratefully received.

Regards Lee.

Link to post
Share on other sites

I started this by typing: "Yes, I' m pretty sure that you can as each channel is discrete within the 5125".

But having thought further, I may not be correct and therefore someone will jump in to put me right.

Let's sort the basic L & R first though then at least you know that is correct.

You take the the "Front" "L" and "R" from the 'Analogue Out" Group (Block "8" in the manual rear cover image) and feed them to two of the 'Inputs' of two channels of the 5125. Ideally these should be the treble card stereo channels (on mine I have these as Channels 5 and 4). You then take two patch leads, one from each of the 'Outputs" of channels 5 an 4 and feed them to the 'Inputs of the bass card  channels - which in this example will now be channels 3 and 2. That will sort your stereo front left and right.

Now, I'm pretty sure that all you need do next is take one lead from the "Centre" RCA of the Analogue Out" Group (Block 8 again) and just feed it to the input of Channel 1 of the 5125. I'm 99% sure that this is correct - I have my centre driven active (and use two mono cards, each in Channel 1 of two 5125s) hence my slight hesitation - but logic tells me that what I've written is correct.

Once that you  have done the above then the only RCA on the back of the 5125 that should remain 'empty' is the channel 1 "out".

Link to post
Share on other sites

Thanks for the reply Dasher, I have the stereo section sorted followed Audiophile Musing activating Katans blog which works great for the Ninka's as well.

Its just the centre I'm struggling with,'ve just rechecked my wiring and I have it as you recommended, I have no output from the centre channel = possibly a fault with channel 1 maybe or I have some other setting incorrect I have centre large speaker enabled on the Exotik and I don't know where to look next I'm glad I have it wired as you said though.

Thanks again for your instructions

Lee.

  • Like 1
Link to post
Share on other sites

What is your source? If it is only a stereo source then you will have no centre channel information. If you are using a Unidisk (or something else that is reading multichannel audio) then it should work.

It's quite a long time since I owned an Exotik but if I recall correctly (and if it is similar to the Kinos and Kisto) then the detected source channel configuration should show up in the display. 

You also should check that the centre speaker is present in the 'Set Up'. You can also set up other parameters for it in the menu.

Edited by Dasher
clarity
  • Like 1
Link to post
Share on other sites

Thanks Dasher yes stereo source so no centre info 9_9 should have sussed that !! 

Link to post
Share on other sites
3 hours ago, LSPC said:

Thanks Dasher yes stereo source so no centre info 9_9 should have sussed that !! 

If you want to check the centre channel, and if your Exotik has the capability (I think that it has),  then selecting "Limbik Party"  by toggling "Surr"  may emulate a centre channel. It will probably sound awful - but it may at least send some content to the speaker.

  • Upvote 1
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...