Sign in to follow this  
wiicrackpot

speaker pop

Recommended Posts

whisper.gifwiiwii, there's something you ought to know about this IceBoy... He cuddled up with Elton John once.:P

But it's good to keep his acquaintance. You could buy a £300 i/c cable from him for £30 should he find another £10 "high-end" cheapie and raves that it gives him better sound.

SS:green:

Share this post


Link to post
Share on other sites

icehockeyboy wrote:

Hi Wii, any friend of Solly's is a friend of mine! :D

Ta Iceboy,slowly finding my way around,once i get into the swing of things, i'll maybe kick some pelicans off their perches here eh!!. :D

Me and Solly goes back a while ago in another time andanother place,hence the Glesga kiss jibeat the top of the thread.

Regards,

wii.

Share this post


Link to post
Share on other sites
Guest Umberto

Hi Andy.

My Mac 2275 used to pop when i switched it off. Apparently they all do that. Nowt to worry about.

Share this post


Link to post
Share on other sites

Injector wrote:

I always give my speakers a glass of Ribena at bedtime.

Mine, being from the North East, demand a pint!

Back to the OP: my Exposure amp, wot I used to have, did this also. Speakers are fine, altho` sulking as they're in the spare room waiting to be part of the upstairs system, having been replaced by the Kudoses.

Share this post


Link to post
Share on other sites

Boxer wrote:

Injector wrote:
I always give my speakers a glass of Ribena at bedtime.

Mine, being from the North East, demand a pint!

Back to the OP: my Exposure amp, wot I used to have, did this also. Speakers are fine, altho` sulking as they're in the spare room waiting to be part of the upstairs system, having been replaced by the Kudoses.

Yeah but a pint isn't 'pop' Boxy! :off:

Share this post


Link to post
Share on other sites

Umberto wrote:

Hi Andy.

My Mac 2275 used to pop when i switched it off. Apparently they all do that. Nowt to worry about.

Hi Umberto,

Glad i don't have to worry about it.

Another question,does your valve from the pre 'flare up' at switch on?, it's only a couple os seconds till it settles to a normal glow,will this shorten valve life?,is there serious problems with this amp?.

Boxer + injector,seconds out,round two.:D

wii.

Share this post


Link to post
Share on other sites

Rob N wrote:

If the valve is an ECC81/82 and European made esp. Mullard/philips then 'flare up' on starting is normal

Thanks Rob,most helpful :^,got this last week and i am hearing and seeing all these things which i haven't experienced in my WAD KIT88 before,seller provided receipts to show all the power amp valves were replaced on March with Chelmers,here's a pic of amp to see if anybody could shed any light on it,i've a lot to learn regarding biasing etc.etc....

But it sounds sublime.

DSCF0934.jpg

DSCF0937.jpg

wii.

Share this post


Link to post
Share on other sites

Didn't want to open another thread,opened up the pre to check condition of valves,it seems they haven't been touched through it's entire so looking to buy new valves to replace them..

DSCF0938.jpg

the bottom right is aMarconi 382 (u.k),is the eec82 a direct replacement,bottom leaft is a mullard eec82 and back two are Mazda 12au7,central one lying on it side is a Mazda (blue writing)but can't make out what it is,what i like to know is has anyone any views of the Full Music and Tubetech equivalents?,should i buy valve dampers for them all?,always led to believe the pre section of amps are the most important for good sound so looking to upgrade them to match the new valves on the power section.

on another note,is there someone on here able to check valves,sellergave meall the valves he swapped out for free,please pm if you can help.

wii.

fook !! just realised my typo,i meant ecc82 :roll:

Share this post


Link to post
Share on other sites
Guest Umberto

wiicrackpot wrote:

Umberto wrote:
Hi Andy.

My Mac 2275 used to pop when i switched it off. Apparently they all do that. Nowt to worry about.

Hi Umberto,

Glad i don't have to worry about it.

Another question,does your valve from the pre 'flare up' at switch on?, it's only a couple os seconds till it settles to a normal glow,will this shorten valve life?,is there serious problems with this amp?.

Boxer + injector,seconds out,round two.:D

wii.

My valves don't flare up at switch on. The Mac is pretty robust in its build and i'm guessing any issues have been mostly dealt with over the years.

Your amp is probably ok.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.