Linn Owners

New router: network problems finding devices

Ruebesound

Newbie
New Wammer
Dec 10, 2021
7
9
3
Switzerland
AKA
Kai
HiFi Trade?
  1. No
Hi all

I got a new internet provider with a new router (FritzBox 7583) and installed it today. Everything works fine, WLAN and LAN are in the same subnet, and I reconnected my MDS and my Sneaky DS to the router via powerline. Also turning on the MDS with the remote the radio started playing, and I can ping the device with the IP adress and call up the web page for config. However, neither Linn Konfig on the laptop (in the LAN) nor Kazoo on the mobile / tablet in the WLAN can find my devices anymore. I already changed the bandwidth in the FritzBox switch part to 100mBit for all ports and WLAN, but that did not help.

Does someone has an idea what to adjust?

Thx, Ruebesound
 
  • Like
Reactions: akamatsu

akamatsu

Michael
Wammer Plus
Oct 9, 2018
7,229
8,112
183
Point Roberts, WA, USA (Vancouver)
AKA
Michael
HiFi Trade?
  1. No
Make sure the DSM and your Mobile/Tablet/Laptop are on the same network. But it sounds like this is the case already. I had disconnect problems the other day and even contacted the Linn helpline. Power cycling the DSM solved the problem.
 
  • Like
Reactions: Ruebesound

Ruebesound

Newbie
New Wammer
Dec 10, 2021
7
9
3
Switzerland
AKA
Kai
HiFi Trade?
  1. No
Make sure the DSM and your Mobile/Tablet/Laptop are on the same network. But it sounds like this is the case already. I had disconnect problems the other day and even contacted the Linn helpline. Power cycling the DSM solved the problem.
Yes, all are in the same network (and subnet), and I can reach the devices on IP-level (technically). They also work on it's own but unfortunately cannot be found by Linn-based SW.
 
  • Like
Reactions: akamatsu

akamatsu

Michael
Wammer Plus
Oct 9, 2018
7,229
8,112
183
Point Roberts, WA, USA (Vancouver)
AKA
Michael
HiFi Trade?
  1. No
I'm not a computer person so I may create more problems than I would solve. If power cycling didn't work, Linn have been having some connectivity issues in the past few days. I've seen it on two separate systems.
 

Moomintroll

Fictional Character - not to be taken literally
Wammer
May 20, 2014
3,516
4,526
148
HiFi Trade?
  1. No
There may be Several problems here.

Firstly, have you power cycled the MDS?

There was an issue with older Fritzboxes, but they may have resolved it -

Fritzbox not seeing the Linn DS/DSM products​

Fritzbox reported having issues with Apple broadcasts and losing connections.
This appear to be due to the Fritzbox monitoring the LAN sockets and shutting down
anything that is not active and going into Green (power saving) mode.
The manufacturer has reported the following fix:
1. Open a web browser and enter "fritz.box" into the address bar to open the router's
configuration page
2. Go in to advanced/expert mode, rather than Wizard mode
3. Go to the "System > Energy Monitor > Settings" pane
4. Set the LAN port that the DS is plugged into to be "always active"
5. Click the "Apply" button

click to enlarge

There may be an issue with Kazoo being on the wrong WLAN -

Android Kazoo questions​

Kazoo cannot find my Linn DS​

In the Android Kazoo App you can select the network (call Subnets),that Kazoo will look for your Linn DS/DSM.

  1. Go into Kazoo settings
  2. Check the Subnets and the Linn DS address range is typically against the (wlan0) number. Select this and use the Android BACK button to go back into the Kazoo app
  3. You should now find your Linn DS/DSM.


On some phone it may switch this setting to the "mobile data" connection and not the Wifi connection.
If your phone supports this try:

  1. Open up Settings on your device
  2. Locate and tap "Data usage" (try using the search within settings)
  3. Locate the app you want to prevent using your data in the background (not all phone support this so do not worry if cannot find this option.)
  4. Scroll to the bottom of the app listing
  5. Tap to enable Restrict background data


If you are still having issue check that you are in the same network as the Linn DS:

  • Repeat steps 1 & 2 from above and take note of the number, (the IP address) stated against '(wlan0)'
  • Go to the Linn DS/DSM with your Linn IR handset. Point the handset to the and press AND HOLD the # button. The first value given is the Linn DS/DSM IP address. Take a note of this number.
On a Sekrit DSM press the rear of the dial to bring up the ">Software update/Properties" page. Press the front of the dial to highlight "Properties" and then press the right of the select this page. Take a note of the IP Address on this page.Compare the number from the Linn DS/DSM and the Android Kazoo. Ignore the last number, the first three number should match each other otherwise the Kazoo app is on the wrong IP address range.E.gKazoo app: 172.55.2.1 & Akurate DS: 192.168.23.49 Kazoo will NOT control the Akurate DSKazoo app: 192.168.23.193 & Akurate DS: 192.168.23.49 Kazoo will control the Akurate DS



As a final check try running Kazoo on a PC/MAC on a wired LAN connection. If this works OK and finds all of the LInn DS players then we suspect the network components may have an issue.

Hope this helps.

’troll
 
  • Like
Reactions: quinn_t and pdcman

Ruebesound

Newbie
New Wammer
Dec 10, 2021
7
9
3
Switzerland
AKA
Kai
HiFi Trade?
  1. No
Thanks for the hints. I am an IT professional (although not specialized in networks), so I tried to rule all that out before posting:

The Fritzbox is a brand new model, and I already looked into the settings: The LAN ports are always active. The device is also working as stated, and also reachable by other devices via http or ping, but not via kazoo.

The subnets to be searched via Kazoo is something that I already checked - all is set correctly - and all devices are definitely in the same subnet, regardless whether via LAN or WLAN. But neither Kazoo not LINN Konfig can find the LINN devices although if I try other protocols they can be found.

I will try it with a separate switch this evening to rule out some FritzBox settings do not interfere, although that would not help with the WLAN problem :(
 
  • Like
Reactions: Moomintroll

Baba Yaga

Wammer
Wammer
Feb 12, 2019
763
632
113
Baba Yaga‘s hut
AKA
BY
HiFi Trade?
  1. No
Can you for testing purposes connect one of the devices via WLAN instead of Powerline to the router?

(Unrelated to your issues I am having a hard time understanding why people would use Powerline connections. many of us are concerned about clean power, great powersupplies, cables, ‚dirt‚ and so on, so why would I voluntarily let my data stream ride on the power line?)
 
  • Like
Reactions: quinn_t

Ruebesound

Newbie
New Wammer
Dec 10, 2021
7
9
3
Switzerland
AKA
Kai
HiFi Trade?
  1. No
Came home from work, testet it with a new switch connected to a Laptop in the sam LAN - no way.
Went for dinner and looked at my mobile after dinner and everything worked - without me changing anything in the config. Apparently the devices just needed time to flash their caches, although that should have happened during reboot?!
However, problem solved, all fine and a big thanks to the supporters here!
 

David Reimers

Newbie
New Wammer
May 11, 2020
22
5
8
I had the same problem 10+ years ago with my DS and a Fritzbox 7390 (I’m also an IT guy). I traced the problem to the Fritz not reliably handing out a DHCP lease to the DS; Linn didn’t allow you to set a static IP: they said that violated the UPnP standard. I later learnt that DHCP is a known weakness of the Fritz models then.

The only fix was full cold power cycling the Fritz each time. I ended up replacing it with a different device.

Some options to consider:

- Separate DHCP server - if you have a NAS, it’ll probably have a DHCP server app available
- Turn off WiFi on the Fritz, and use a separate wireless router (with its WAN port being plugged into a Fritz LAN port)
- also look at IGMP snooping - some routers don’t do this well and some don’t forward those packets between the wired and wireless networks, so this could be a problem
 

Solanum

Wammer
Wammer
Oct 9, 2018
496
465
68
HiFi Trade?
  1. No
Ah, the joys of Linn's OhNet protocol. Some (lots, including decent consumer stuff) networking gear simply don't deal with multicast in the way that OhNet demands. I'm not sure whether anyone outside of Linn really knows what the problems are (or why they designed it in such a way that it doesn't play nice with lots of consumer networking hardware). Upnp to Linn DSM will work just fine, but OhNet will not.

I don't know how much gear I went through before I found stuff that OhNet doesn't have problems with. In the end I replaced everything with Unify hardware, it's a bit overkill for the average home, but I have had no problems with anything (Linn or otherwise) since moving over to it. Whilst it isn't cheap, it is no more expensive than the higher spec consumer Netgear kit. I don't worry about my home network at all any more, so it is worth it.

I bridge the crappy box from my ISP to the Unify router, so I don't have to worry about that either.

Anyway, my experience is that it isn't worth fighting against Linn's quirks...
 

Baba Yaga

Wammer
Wammer
Feb 12, 2019
763
632
113
Baba Yaga‘s hut
AKA
BY
HiFi Trade?
  1. No
Using Fritz box and repeater here myself without any issues.
What I noticed though is that the AVM Mesh functionality often leads to trouble (Zoom sessions, dropouts), so I‘m not using it.
 

Forum statistics

Threads
113,444
Messages
2,451,263
Members
70,783
Latest member
reg66

Latest Articles

Wammers Online